Start wxWidgets programming on Linux/OSX

  |   Source

wxWidgets programming on Linux/OSX :linux:en:wxwidgets:

wxWidgets 3.0.0

WARNING: before building, please make sure remove everything in build directory, including hidden directory!

Install webkit by using Linux distribution's package manager

I need use wxWebView which dependent on webkit on Linux. The issue here is that webkit on Linux is using GTK.

Make sure the webkit and wxWidgets are using same version of GTK.

build the source

Please note I don't use libtiff. I think libpng and libjpeg is enough.

mkdir -p ${WXWIN}/build-release;cd ${WXWIN}/build-release;../configure --disable-shared --without-libtiff;make
mkdir -p ${WXWIN}/build-debug;cd ${WXWIN}/build-debug;../configure --disable-shared --enable-debug --without-libtiff;make

On OSX, I need extra --with-osx_cocoa parameter for configure.

On Linux, build will be fine following above steps. But for building application, I need sudo apt-get install libgtk2.0-dev on Debian/Ubuntu/Mint.

Comments powered by Disqus